Critical Splunk Enterprise Vulnerability Lets Unauthenticated Attackers Execute OS Commands

Splunk has disclosed a critical vulnerability in Splunk Enterprise that allows unauthenticated attackers to execute operating-system commands through an exposed Patroni REST API.

Tracked as CVE-2026-76268, the flaw carries a CVSS v3.1 score of 9.8 and affects search head cluster members running vulnerable releases in the 10.4 and 10.2 branches.

The vulnerability stems from missing authentication for critical configuration operations in the Patroni interface. An attacker needs network access to that interface on a search head cluster member, but does not need a Splunk account or user interaction.

Critical Splunk Enterprise Vulnerability

CVE-2026-76268 affects Splunk Enterprise 10.4 releases before 10.4.3 and 10.2 releases before 10.2.7. Splunk explicitly states that the 10.0.x and 9.4.x branches are not affected by this particular vulnerability.

The attack condition is access to the Patroni REST API, rather than simply access to Splunk Web. This distinction matters when assessing which deployed cluster members expose the vulnerable interface.

The advisory credits Splunk researcher Gabriel Nitu with discovering the flaw. It does not provide an exploit payload, identify active exploitation, or describe a publicly available proof of concept.

Consequently, the disclosure establishes a serious unauthenticated command-execution risk without confirming that attackers have exploited it in operational environments.

The same advisory documents 17 vulnerabilities: one critical, one high, and 15 medium-severity issues. The high-severity flaw, CVE-2026-76266, allows a local attacker operating as the Splunk service account to manipulate installation content so a subsequent Linux package upgrade executes attacker-controlled commands as root.

Exploitation requires an affected upgrade after the installation is modified; it is not unrestricted, immediate privilege escalation.

Other weaknesses expose search queries, job metadata, results, and private SPL2 module definitions. CVE-2026-76274 enables server-side request forgery that can disclose an Observability Cloud API token.

Several Secure Gateway flaws permit unauthorized payload signing or modification of alert and mobile-device recipient data. These issues require authenticated access or specified capabilities, unlike the critical Patroni vulnerability.

Splunk recommends upgrading to Enterprise 10.4.3, 10.2.7, 10.0.10, or 9.4.15, or later releases. Organizations not using Edge Processor, OpAmp, or SPL2 data pipelines can mitigate CVE-2026-76268 by setting disabled = true under [postgres] in $SPLUNK_HOME/etc/system/local/server.conf, then restarting Splunk Enterprise.

Additional remediation is required for four flaws. CVE-2026-76264 requires setting scripted_lookup_raw_write_enforcement = block under [lookup] in limits.conf after upgrading and restarting.

CVE-2026-76265, CVE-2026-76272, and CVE-2026-76280 require Secure Gateway upgrades to 3.10.11, 3.9.25, or 3.8.72, or higher. Splunk also documents disabling affected apps where upgrades cannot be completed, subject to feature dependencies.

The table covers all 17 CVEs verified in SVD-2026-1001. SVD-2026-1002 could not be retrieved despite repeated attempts, and a targeted search returned no results; any additional CVEs in that advisory remain unverified.

CVESeverity / CVSS v3.1Vulnerability and impactAffected Enterprise releases / remediation
CVE-2026-76264Medium / 4.3Improper authorization allows scripted lookup definitions to be created or edited through raw configuration endpoints.Before 10.4.2, 10.2.6, 10.0.10, and 9.4.15; enable scripted_lookup_raw_write_enforcement = block after upgrading.
CVE-2026-76265Medium / 6.5Secure Gateway REST endpoints expose privileged functionality, including signing attacker-controlled payloads.Before 10.4.3, 10.2.7, 10.0.10, and 9.4.15; also upgrade Secure Gateway to 3.10.11, 3.9.25, or 3.8.72, or higher.
CVE-2026-76266High / 7.7Modified installation content can trigger root-level command execution during a subsequent Linux package upgrade.Linux releases before 10.4.3, 10.2.7, 10.0.10, and 9.4.15; tar-based upgrades provide a workaround.
CVE-2026-76267Medium / 4.3Users with read_o11y_content can inject forged app-log entries through SignalFlow content.Before 10.4.3, 10.2.7, and 10.0.10; 9.4.x unaffected.
CVE-2026-76268Critical / 9.8Missing Patroni REST API authentication permits unauthenticated OS command execution.Before 10.4.3 and 10.2.7; 10.0.x and 9.4.x unaffected.
CVE-2026-76269Medium / 6.5Insufficient ownership checks expose other users’ search queries, metadata, results, and previews.Before 10.4.3, 10.2.7, 10.0.10, and 9.4.15.
CVE-2026-76270Medium / 6.5SPL2 module-filtering SQL injection exposes data, including private module definitions.10.4 releases before 10.4.3; 10.2.x, 10.0.x, and 9.4.x unaffected.
CVE-2026-76271Medium / 6.5Inefficient regular-expression validation permits denial of service against an Observability app endpoint.Before 10.4.3, 10.2.7, and 10.0.10; 9.4.x unaffected.
CVE-2026-76272Medium / 4.3Missing authorization allows users to request signatures for attacker-controlled payloads.Before 10.4.3, 10.2.7, 10.0.10, and 9.4.15; also upgrade Secure Gateway to fixed releases.
CVE-2026-76273Medium / 4.3Improper collect index-name validation permits attacker-controlled content in system-level messages.Before 10.4.3, 10.2.7, 10.0.10, and 9.4.15.
CVE-2026-76274Medium / 6.5SSRF redirects outbound requests to an attacker-controlled host, disclosing the configured Observability Cloud API token.Before 10.4.3, 10.2.7, and 10.0.10; 9.4.x unaffected.
CVE-2026-76275Medium / 4.3Search-job listings expose other users’ query text and execution metadata.Before 10.4.3, 10.2.7, 10.0.10, and 9.4.15.
CVE-2026-76276Medium / 4.3Embedded JavaScript source maps disclose original Discover Splunk Observability Cloud app source code.Before 10.4.3, 10.2.7, and 10.0.10; 9.4.x unaffected.
CVE-2026-76277Medium / 4.1Trailing-period usernames can share configuration data or disrupt account-management operations.Before 10.4.3, 10.2.7, 10.0.10, and 9.4.15; requires edit_user.
CVE-2026-76278Medium / 4.3Authorization bypass exposes permission grants for inaccessible SPL2 modules.Before 10.4.3, 10.2.7, and 10.0.10; 9.4.x unaffected.
CVE-2026-76279Medium / 4.3Whitespace handling in collect index names bypasses restrictions on writing to internal indexes.Before 10.4.3, 10.2.7, 10.0.10, and 9.4.15; remove run_collect from roles without internal-index access as a workaround.
CVE-2026-76280Medium / 6.3Unrestricted Secure Gateway KV Store writes allow changes to alert and mobile-device recipient data.Before 10.4.3, 10.2.7, 10.0.10, and 9.4.15; also upgrade Secure Gateway to fixed releases.

Join 16,000+ SOC teams using ANY.RUN to streamline threat investigations and reduce manual effort. Explore for your team 

Tamilselvan
Tamilselvanhttps://cyberpress.org/
Tamilselvan is an Investigative cybersecurity journalist dedicated to breaking stories on ransomware cartels, data breaches, and state-sponsored espionage.

Trending News

Related Stories